Dieser Artikel erschien ursprünglich in meinem ersten Weblog das Netzbuch, das von Mai 2002 bis November 2006 aktiv war, und wurde hier aus blognostalgischen Gründen archiviert. Aktuellere Artikel hat der Uninformat im Angebot.
Zeugs

Firefox unter Windows XP - Eine Leidensgeschichte

Ich weiß, Mozilla Firefox ist everybody’s darling, besonders in Bloggerkreisen. Aber der Feuerfuchs und ich kommen einfach nicht zusammen.

Im Büro habe ich (leider) Windows XP im Einsatz. Da MSIE bekanntlich völlig indiskutabel ist, habe ich wie jeder vernünftige Mensch den Feuerfuchs installiert. Mit 0.8 lief es eigentlich gut. Eigentlich. Der Browser läuft bei mir den ganzen Tag, in einem Tab eine Auswertung der Firmenwebsite, die ich ab und an mal “refreshe”. Der unangenehme Nebeneffekt war, dass der Tab seine “History” vergaß und die Seite sich nicht mehr aktualisieren ließ, man konnte Ctrl-R drücken so oft man wollte, es passierte nichts mehr. Erst wenn man den URL in einen anderen Tab übernahm, funktionierte es wieder einige Zeit.

Dieser Bug blieb in 0.9.x erhalten. Dazu kamen weitere “Features” wie gelegentliches völliges Einfrieren des Firefox, sehr angenehm wenn man gerade in 13 Tabs arbeitet. Frame-Seiten wie phpMyAdmin funktionieren nicht richtig, nach einiger Zeit wird das Hauptfenster nicht mehr aktualisiert. Vor ein paar Tagen funktionierte der Fuchs überhaupt nicht mehr, ich legte ein neues Profil an, aktualisierte auf 0.9.3, und hoffte dass alles gut werden würde. Wurde es aber nicht, seit gestern funktioniert keinerlei Datenübermittlung via GET mehr. Nun habe ich den “richtigen” Mozilla 1.7.3 installiert, noch geht alles. ;-)

Spaßeshalber habe ich den Firefox gestern auch mal im Home-Office unter WinXP installiert (da lief bisher ebenfalls ein “richtiger” Mozilla), da startet er gar nicht erst. Liegt bei mir auf der Kombi “Firefox und Windows” ein Fluch, oder ist die Win-Version wirklich so buggy?



11 Kommentare



Boris am 14.09.2004:


Ich verwende FF 0.9.2 sowie Moz 1.7.2 gleichermaßen – natürlich mit komplett getrennten jeweils eigenen Profilen. Hatte mit beiden seit Ewigkeiten keinerlei Probleme, weder unter 2K noch unter XP. Schon gar keine Abstürze oder sonst merkwürdiges Verhalten. Beide habe ihre Plugins im eigenen Verzeichnis (copy&paste), und beide haben diverse Extensions und Themes installiert. Ich verstehe das irgendwie nicht, wieso es bei anderen unter vergleichbaren Voraussetzungen herbe Probleme gibt.
Was läuft da vielleicht noch im Hintergrund, was Ärger machen könnte?
Bei Neuinstallationen immer schön in einen ganz frischen Ordner installiert? Dann die Plugins rüberkopiert und die alte Installation gelöscht?
Tipp: zum Testen mit einer neuen Installation auch mal vorher den /chrome – Ordner im Profilverzeichnis ersatzlos löschen (Bookmarks und pers. Einstellungen bleiben trotzdem erhalten, nur die Extensions und Themes muss man neu installieren).

Übrigens: auch den Thunderbird habe ich für einige Mailaccounts installiert, also die ganze Mozilla-Palette auf einen Haufen, völlig problemlos…

Gerrit am 14.09.2004:

Die Mac-Version kommt mir unausgereifter vor – vor allem wegen der langen Startzeit. Auf meinem ollen Win98-System habe ich bisher noch nie Probleme gehabt, da rockt Firefox sehr!

Ralf am 14.09.2004:

Verstehe ich alles nicht, ich mache mit dem Firefox (und dem System sowieso nicht ;-)) nix außer ihn zu benutzen. Also doch ein Fluch. ;-)

Marc am 14.09.2004:

Mein 0.9.3 Firefox funktioniert unter XP mit drei Einschränkungen: Er erkennt nciht alle Flash-Seiten (kann aber auch ein Fehler meinerseits sein), er schmiert ab, wenn ich sehr sehr viele Tab geöffnet habe und er “vergisst” regelmäßig das Häckchen bei “Pop-up-Fenster immer blockieren”.

helge am 14.09.2004:

bei mir funktioniert die kombination firefox 0.8, 0.9.3 und thunderbird auf zwei win2k maschinen problemlos, wenn man von kleinigkeiten, wie sie auch marc erwähnt, absieht. im gegensatz zum IE zeigt der fuchs auch kein schlimmes memory leak, wenn ich ihn mal ein paar tage lang durchgehend verwende.

Picotto am 14.09.2004:

Bin ich denn der einzige bei dem (unter XP) alles so läuft wie es sein soll? Es gibt keine Probleme mit Flashseiten, er stürzt selbst bei 30 Tabs gleichzeitig nie ab, der PopUpBlocker tut seit der Installation was er tun soll, die History und andere gespeicherte Dinge werden erst dann gelöscht wenn ich es will und phpMyAdmin läuft auch problemlos. So war es bei Version 0.8 und so ist es auch in 0.9.3. Irgendwas macht ihr falsch ;)

Ralf am 14.09.2004:

Scheint so, Picotto! Möglicherweise merkt das Windows, dass ich es nicht leiden kann, und macht mir deshalb absichtlich den FF kaputt.;-)

Marco am 14.09.2004:

Unter Linux habe ich auch das Problem mit dem Refreshen, auch Strg+W tut manchmal nicht mehr. Unter win2k gibts aber keine Probleme :)

Christoph am 15.09.2004:

Ich verwende seit gestern Firefox 1.0PR unter WinXP, davor 0.9.2, immer ohne Probleme. Einziger ‘Bug’: Wenn mir Windows abschmiert, schreibt Firefox danach den Cache neu und verliert die Website-Icons.

Jürgen R. Plasser am 15.09.2004:

Ich verwende nun Firefox schon länger als ein Jahr unter XP als auch unter Linux und bin sehr zufrieden.

Unter WinXP hatte ich bisher selten wirklich Probleme, die 0.93er Version ist sehr stabil. Unter Linux habe ich damit mehr Troubles, es hält sich aber in engen Grenzen.

Die oben beschriebenen Probleme sind mir aber völlig unbekannt. Ich erinnere mich aber, bei Updates die bestehenden Profile und Extensions (vor allem alte Extensions, pre0.9) gelöscht zu haben, weil das damals zu unerwarteten Crashes und Freeces führte. Da ich auch eine kleine Extension für Firefox programmiere weiß ich, dass Extensions eine sehr fragile Sache sind; ein XML-Tag nicht geschlossen und der ganze Browser steht da und guckt saublöd. Vielleicht hast Du alte Extensions, die dir das Firefox-Leben schwer machen?

roland am 16.09.2004:

ich hab ja von dem kram keine ahnnung, aber ich verwende eines dieser irgendwie “optimierten” versionen von firefox von moox:
http://www.moox.ws/tech/mozilla/

insbesondere die ladezeit hat sich da bei mir gebessert, und vom refreshfehler merke ich auch nix.